2015年3月13日 星期五

iPad mini iOS 8.1.3 更新為 iOS 8.2


等了兩天,忍不住來更新了, iOS 8.2


官方更新說明如下:

此版本介紹了 Apple Watch 的支援,且包含「健康」App 的改進內容、改進的穩定性和錯誤修正。

Apple Watch 支援
•     全新的 Apple Watch App 可與 iPhone 配對和同步,以及自定手錶設定
•     新的「活動記錄」App 可用於檢視來自 Apple Watch 的體能訓練資料和成就;會在
     Apple Watch 配對時顯示
•     適用於 iPhone 5 和更新機型

「健康」App 改進內容
•     加入了可選擇距離、體溫、身高、體重和血糖等測量單位的功能
•     改進了在處理大量資料時的穩定性
•     包含了可從第三方 App 加入和顯示體能訓練階段的功能
•     解決了可能會導致使用者無法在醫療卡中加入照片的問題
•     修正了維生素和礦物質的單位
•     修正了「健康」資料在更改資料來源順序後無法重新整理的問題
•     修正了部分圖形不會顯示資料值的問題
•     加入了隱私權設定,可讓您停用追蹤步數、距離和爬樓梯段數

穩定性改進內容
•     增加了「郵件」的穩定性
•     改進了「地圖」中 Flyover 的穩定性
•     改進了「音樂」的穩定性
•     改進了 VoiceOver 的可靠性
•     改進了 Made for iPhone 助聽器的連接效能

錯誤修正
•     修正了使用「地圖」時無法導航至部分喜好位置的問題
•     解決了快速回覆訊息中最後一個字不會自動更正的問題
•     修正了重複的 iTunes 購買內容會導致 iCloud 回復無法完成問題
•     解決了部分 iTunes 的音樂或播放列表不會同步至「音樂」App 的問題
•     修正了已刪除的有聲書有時候仍會保留在裝置上的問題
•     解決了可能導致在使用 Siri 免看功能時,來電語音無法轉接至車用音響的問題
•     修正了在接聽來電前無法聽到語音的藍牙呼叫問題
•     修正了「行事曆」事件會以 GMT 顯示的時區問題
•     解決了會導致自定重複會議中的某些事件從 Exchange 行事曆中除去的問題
•     修正了無法透過第三方閘道設定 Exchange 帳號的憑證錯誤
•     修正了可能導致發起人的 Exchange 會議備忘錄遭覆寫的問題

•     解決了會使部分「行事曆」事件在接受邀請後無法自動顯示為「忙碌」的問題



相關資源:

2015年3月12日 星期四

Symantec 內嵌資料庫無法啟動

今天一早來就發生慘案,在檢查所有伺服器運作是否正常時發現,防毒軟體與中控失去連線。

正要打開 Symantec Endpoint Protection Manager 遠端主控台時又無法連線,只好用遠端桌面連到中控主機看一下。不看還好,一看卻發現,磁碟空間不足......Orz

這一台主機是躲在 Hyper-V 裡面的一台虛擬主機,由於資料庫每天增加而導致磁碟空間一天一天的長大,只好先將該虛擬主機關閉並擴充磁碟空間,重新啟動該虛擬主機。

解決了空間問題後,接下來到服務看一下 Symantec 內嵌資料庫,怎麼手動啟動都啟動不了,進去該服務執行,中控系統也自動發信出來告知【Symantec Endpoint Protection Manager 資料庫已關閉需要立即加以處理】。


到存放 DB 的目錄查看又發現, DB 與 Log 的日期不一致,真慘...應該是磁碟空間不足而無法寫進 Log ,造成 DB 無法開啟。


看了一下 Error Log ,也是指出無法開啟指定的檔案。


看來只好先修復資料庫,讓資料庫重新產生 Log 檔。
首先,先將 Log 檔重新命名。



在打開命令提示字元,利用【dbsrv12】的指令來修復資料庫,由於指令在提示字元下還是會認 8+3 的檔案名稱,所以就下指令【dbsrv12 -f C:\Progra~2\Symantec\Symant~1\db\sem5.db】

完整路徑:C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\db

而【dbsrv12】該檔案是存放在【C:\Progra~2\Symantec\Symant~1\ASA\win32】之下

完整路徑:C:\Program Files (x86)\Symantec\Symantec Endpoint Protection Manager\ASA\win32

所以在命令提示字元下我們需鍵入【C:\Progra~2\Symantec\Symant~1\ASA\win32\dbsrv12 -f C:\Progra~2\Symantec\Symant~1\db\sem5.db


鍵入好指令後並按【Enter】,此時就會開啟資料庫修復工具的視窗,待修復完畢後,視窗會自動關閉。


資料庫修復後,我們重新回到【服務】裡,重新啟動【Symantec 內嵌資料庫】。這時候就可以正常的啟動該服務了。


回過頭來去看一下 DB 與 Log ,這時候時間都是一致的。


看一下 Client 與 Server 端,所有的 Symantec Endpoint Protection 都已經正常和中控連線上了。


在找時間來壓縮一下資料庫好了,收工!!!


相關資源:
Error when logging to Symantec Endpoint Protection Manager: "Failed to connect to server". Unable to start the embedded database service.